
Cultural Moments
Activities & Resources
A toolkit for Educators looking to celebrate popular  
holidays and significant moments with their students.



1. International Women’s Day 
2. World Health Day
3. Women’s Equality Day
4. Read A Book Day
5. International Literacy Day

a. Literary Classics + Bookmarks
b. Bookmarks

6. Hispanic Heritage Month
a. Crossword puzzle
b. Report + passport 

7. World Mental Health Day
a. Guided meditation
b. Self-care journal

8. Halloween
a. Build a monster
b. Color by numbers + mad lib 

9. Native American Heritage Month
10. World Kindness Day
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11.   Winter Holidays
a. Ugly Sweater Activity
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18.   Back to School 

c. Bulletin Board 
d. Icebreaker 
e. Goal Setting Worksheet 

19. Thanksgiving 
20. New Year 
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World Health Day
Journaling Activity



This World Health Day, encourage students to journal 
about how they are looking after their wellbeing during 
distance learning.

By making their own copy of this Google Slides 
template, students can use text and stickers to provide 
feedback. This can serve as a great resource for 
checking in with students.

About this activity

https://docs.google.com/presentation/d/153JwxN325NHl5wKX5OlEwoQs7OinPjYC_FX-QXywU4w/copy
https://docs.google.com/presentation/d/153JwxN325NHl5wKX5OlEwoQs7OinPjYC_FX-QXywU4w/copy
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Women’s Equality Day
Virtual Poster Board & Playlist Report



This #WomensEqualityDay, we’ve created a 
#GoogleSlides template for teachers and students to 1⃣ 
research, 2⃣ celebrate, and 3⃣ bring visibility to the 
suffragettes who fought for women's voting rights in 
the US.

By making their own copy of this Google Slides 
template, students can use text and stickers to provide 
feedback. This can serve as a great resource for 
checking in with students.

About this activity

https://docs.google.com/presentation/d/1HqkvAPwpzLtLGLf4IVZ_ax_arPymKmGsE5hN6ogAQxc/copy
https://docs.google.com/presentation/d/1HqkvAPwpzLtLGLf4IVZ_ax_arPymKmGsE5hN6ogAQxc/copy


Dive into this curated playlist to uncover a brief history 
of Women’s Suffrage, then encourage your students to 
share their learnings with classmates using a Google 
Slides book report. 

To get started, open this Slides deck and make a copy 
by selecting File > Make a copy > Entire presentation. 

About this activity

https://youtube.com/playlist?list=PLydZ2Hrp_gPSlb4POBja-0R5tbSSEWlq5
https://docs.google.com/presentation/d/1XtbJCEZ2HgmtyXCRifBLKbJ97G6pANP0BJKaZAfMXlY/edit?usp=sharing
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Read A Book Day
Virtual Bookshelf



This Read A Book Day, encourage students to continue 
their reading journeys with this virtual bookshelf that 
students can use to document recent reading and 
share with classmates, teachers, and parents.

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to present their virtual bookshelves to the class, either 
in-person or virtually.  

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image 
appears on the Slide, right click on the image and 
select Order > Send to back to ensure the colorful 
graphic is visible.

About this activity

https://docs.google.com/presentation/d/1GSH4GB1Tcc3ptXEN0Rdsf13nMVg99QKgVeceDCsOisw/edit?usp=sharing&resourcekey=0-PgsD4OFh40n5f3lpg9YtBg
https://docs.google.com/presentation/d/1GSH4GB1Tcc3ptXEN0Rdsf13nMVg99QKgVeceDCsOisw/edit?usp=sharing&resourcekey=0-PgsD4OFh40n5f3lpg9YtBg
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International Literacy Day



Celebrate International Literacy Day with this YouTube 
playlist and make-your-own bookmark activities. 

To get started, make a copy of this slides deck by 
selecting File > Make a copy > Entire presentation.  

About this activity

https://docs.google.com/presentation/d/1cEzt7X86jYsk50KQTZBtFgPMd03Rho60xe9Iijc6lM4/edit?usp=sharing


This International Literacy Day, express the importance 
of literacy and encourage students to keep reading 
with free downloadable bookmarks 

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their bookmarks.  

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image 
appears on the Slide, right click on the image and 
select Order > Send to back to ensure the colorful 
graphic is visible.

About this activity

https://docs.google.com/presentation/d/1SRZIBQVf5mVlgHMljYco2qPwl6Sun5xNCEC8T5i646E/edit#slide=id.p
https://docs.google.com/presentation/d/1SRZIBQVf5mVlgHMljYco2qPwl6Sun5xNCEC8T5i646E/edit#slide=id.p
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Hispanic Heritage Month



This Hispanic Heritage Month, celebrate with your 
students using this crossword puzzle featuring terms 
from Hispanic culture and the names of accomplished 
Hispanic Americans.

Make a copy of this Google Slides template. Keep your 
copy of Slides 3 & 4 as the answer key, but be sure to 
remove these Slides before students make a copy.

About this activity

https://docs.google.com/presentation/d/1LKgtj0jDzOFoePX35N5mxN8xpapwv0_YeirT-55vXmo/copy


Take your students on a trip this Hispanic Heritage 
Month. Using this ready-to-go report template and 
virtual passport, students can explore different 
Hispanic countries and share their learnings with the 
class. 

Head to this Google Slides template to get started. 
Make a copy by selecting File > Make a copy > Entire 
presentation. 

About this activity

https://docs.google.com/presentation/d/1S2uGJMue7zUdsTVewVde9LkT1qB8SFT3muSqOlE43lA/edit?usp=sharing
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World Mental Health Day



This World Mental Health Day, support your students in 
their self-care practices. Use this guided meditation 
exercise to teach about the benefits of mental and 
emotional health 

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their meditations.  

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image 
appears on the Slide, right click on the image and 
select Order > Send to back to ensure the colorful 
graphic is visible.

About this activity

My calm place

https://docs.google.com/presentation/d/1QJ42E4q1IC8Fw0cKQScI_4InvvQ0T8Jky9PvLGsd6mw/copy
https://docs.google.com/presentation/d/1QJ42E4q1IC8Fw0cKQScI_4InvvQ0T8Jky9PvLGsd6mw/copy


This World Mental Health Day encourage your students 
to reflect on how they exercise self-care through this 
ready-to-use journal in Google Slides. 

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their journal.  

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image 
appears on the Slide, right click on the image and 
select Order > Send to back to ensure the colorful 
graphic is visible.

About this activity

https://docs.google.com/presentation/d/1_MEi-N7RpayiNezPSc7xgE645LY7rGQ9h1Mfqi24f00/edit?usp=sharing
https://docs.google.com/presentation/d/1_MEi-N7RpayiNezPSc7xgE645LY7rGQ9h1Mfqi24f00/edit?usp=sharing
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Halloween



This Halloween, guide your students in building their 
own monsters using mix-and-match body parts, or 
drawing their own, to create never-before-seen 
creatures.

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their monsters.  

About this activity

https://docs.google.com/presentation/d/1xH8DI21JZZFYdWEwKOJ8Ca5VCUStafbNG4UU7dF_SUQ/copy
https://docs.google.com/presentation/d/1xH8DI21JZZFYdWEwKOJ8Ca5VCUStafbNG4UU7dF_SUQ/copy


Treat your class this Halloween with some frightfully fun 
and printable activities available in Google Sheets. 
Students can complete a spooky mad lib or try color by 
numbers to create some fun Halloween images. 

Open this Google Sheet to get started (if you dare). 
Make a copy by selecting File > Make a copy > Entire 
presentation. 

About this activity

https://docs.google.com/spreadsheets/d/1ahqQDFNxGBZH9T_6ORIZ2MAifF1SZwl19or9EQJ_oF0/edit?usp=sharing
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Native American Heritage Month
Research Report



This Native American Heritage Month and every month, 
celebrate the culture and heritage of Native Americans who 
deeply enrich the quality and character of the United States. 
Use this resource with your students to learn about and honor 
their heritage.

By making their own copy of this Google Slides template, 
students can use text, images, and stickers, to customize 
their report.

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image appears on 
the Slide, right click on the image and select Order > Send 
to back to ensure the colorful graphic is visible.

About this activity

https://docs.google.com/presentation/d/1f3E9cKRjRFsX1krKespelHBcrTFiVPfQ3wb2Yhs7oUI/copy
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World Kindness Day
Compliment Chain



This #WorldKindnessDay, set off a chain reaction in your 
classroom, using this compliment chain activity to 
encourage students to share positive feedback.

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their compliment chains 

About this activity

https://docs.google.com/presentation/d/16_HtSqT8FX8TDcii53WARJlRY1Dcc4-ks-q2VbdpTm0/copy
https://docs.google.com/presentation/d/16_HtSqT8FX8TDcii53WARJlRY1Dcc4-ks-q2VbdpTm0/copy
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Winter Holidays



During the Winter holiday, use this Google Slides 
resource with students so that they can create their 
own ugly sweater. 

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their look.  

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image 
appears on the Slide, right click on the image and 
select Order > Send to back to ensure the colorful 
graphic is visible.

About this activity

https://docs.google.com/presentation/d/1yUdl5bntOULJFNyST5A9CdYAvzi0znPrnXXxDeReLBk/copy
https://docs.google.com/presentation/d/1yUdl5bntOULJFNyST5A9CdYAvzi0znPrnXXxDeReLBk/copy


Students can take home some holiday spirit with this 
craft activity in Google Slides. Have your class design 
their own greeting cards with font, backgrounds and 
stickers of their choice. 

Open this Google Slides deck to get started. Make a 
copy by selecting File > Make a copy > Entire 
presentation. 

About this activity

https://docs.google.com/presentation/d/1QLVv2Zaknaw_tnXnr6RTOuG1dmj9mF2gmkmV6153myQ/edit?usp=sharing


Proprietary + Confidential

Black History Month



This Black History Month, encourage students to 
research the rich legacy of Black Americans. Using 
Google Slides, students can organize their findings and 
present their learnings. 

Make a copy of this Slides template. Students can use 
text, images, and stickers, to customize their exhibit.

To add portraits, select Insert > Image. You will be 
prompted to choose an option. Once the image 
appears on the Slide, right click on the image and 
select Order > Send to back to ensure the colorful 
graphic is visible.

About this activity

https://docs.google.com/presentation/d/1lDrxBI7YMAgkeGryAzA1FTgCyPu444DazX4W00tabL0/copy


Challenge your students to go beyond what they 
know and discover something new this Black 
History Month. Students can explore the people, 
places, and events that they want to learn more 
about and share their findings using this 
customizable research template  in Google Slides. 

Open this deck to get started. Make a copy to gain 
access by selecting File > Make a copy > Entire 
presentation. 

About this activity

https://docs.google.com/presentation/d/1_l6KNqU_3FenrIyUPpfthPZaMzulRmFFmGbGRCkzjus/edit?usp=sharing
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National Inventors’ Day
Invention Machine Activity



Kick off National Inventors’ Day in your classroom with 
this engaging Jamboard activity, which allows students to 
use various machines to create their own invention. 

By making their own copy of this Jamboard template, 
students can use text, images, and stickers, to 
customize their invention.

About this activity

https://jamboard.google.com/d/1MANyCbDKDTMRzZSU_II0AC-_gWSxfulxCcMFLDx_1QI/copy
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World Oceans Day
Field Journal



This World Oceans Day, encourage students to gain an 
understanding of, and appreciation for, the ocean by 
completing a field journal using Google Earth. 

Dive into this Slides deck to get started! Make a copy 
by selecting File > Make a copy > Entire presentation. 

About this activity

https://docs.google.com/presentation/d/1_VE1DTaeoHb0VIW2wRM8TZgf9a45DyHSZ4e2qFIOnds/edit?usp=sharing
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Women’s History Month



This year, tell HER-story. Grab a copy of this 
hot-off-the-press Magazine template and inspire your 
students to honor the iconic women in their lives.

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to customize their magazines. 

About this activity

https://docs.google.com/presentation/d/1C85I2kQEIU01tqCpEmgNqsCkODdrJyw_kJljLuRZpys/copy
https://docs.google.com/presentation/d/1C85I2kQEIU01tqCpEmgNqsCkODdrJyw_kJljLuRZpys/copy
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History and creativity meet with this Women’s History 
Month activity. Have your students customize 
postcards from the point of view of different historical 
figures. 

Open this Slides deck to get started! Make a copy by 
selecting File > Make a copy > Entire presentation. 

About this activity

https://docs.google.com/presentation/d/1VMez5pVTLQJOsj7Hk1BT79v40nNoLzUm0i3OOmg5Fws/edit?usp=sharing


This International Women’s Month, encourage 
students to research and celebrate the achievements 
and contributions of women throughout history using 
a virtual poster board. 

By making their own copy of this Google Slides 
template, students can use text, images, and stickers, 
to present their virtual poster boards to the class, 
either in-person or virtually.  

Shedding light on the rich history of women 
throughout time, across disciplines, and beyond 
borders can help students reflect on the significance 
of inclusion in the past, present, and future.

About this activity

https://docs.google.com/presentation/d/1OzLP7fc8617HVbWXlUeV0P56RkkcoJgoTUiKeLhGdH8/copy
https://docs.google.com/presentation/d/1OzLP7fc8617HVbWXlUeV0P56RkkcoJgoTUiKeLhGdH8/copy
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National Pet Week
Build a Pet



Let your students’ imagination run wild this 
#NationalPetWeek with this fun classroom activity. 
Students can build their own pet using a variety of 
images and stickers in #GoogleSlides.

By making their own copy of this Slides deck, students 
will be steps away from bringing their own furry best 
friend to life.

About this activity

https://docs.google.com/presentation/d/1Cu0iAX4frCX3i592BtShc7q3bZeuEADzQesKWWemfyA/copy
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Mental Health Awareness Month
Gratitude Journal



Encourage your students to practice mindfulness 
during #MentalHealthAwarenessMonth with this 
gratitude journaling activity in #GoogleSlides. 

By making their own copy of this Slides deck students 
can reflect on what they’re thankful for. 

About this activity

https://docs.google.com/presentation/d/1_Vh_PzxBTLGdXjO5ctFuV86JJpf-lhk9R24NzNOmYeQ/copy
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Back to School 



Give your classroom a personal touch this school year 
with customizable bulletin board templates, available in 
both online and printable format. Encourage students 
to get to know one another using fun and engaging 
prompts, or create your own ice breakers!

Open this Slides deck to get started! Make a copy by 
selecting File > Make a copy > Entire presentation. 

About this activity

https://docs.google.com/presentation/d/1GqAd00q-HFqChQTMpu9sKq9-mawnEAEWWJpyPA44SHI/edit?usp=sharing


Looking for a fun and engaging icebreaker activity to 
help your students get to know one another? Try this 
interactive bingo game in Google Slides, available in 
online and printable formats. 

Open this Slides deck to get started! Make a copy by 
selecting File > Make a copy > Entire presentation. 

About this activity

https://docs.google.com/presentation/d/1kZBelhKfg6rjopfa7cPOuTvqkjSbtXssFwIburLbpfM/edit?usp=sharing
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Semester in review



Semester in Review 

Take a look back at your semester and share your 
favorite moments. 

To get started, click here select File > Make a Copy > 
Entire Presentation to make a copy of the template. 

Want to share it? Save your image as a .jpg by going to 
File>Download>JPEG image (.jpg, current slide). 

https://docs.google.com/presentation/d/1-QoYLSadHvJM1zaXs42v5mvfTVsL8yiCfW8YuRwuUNk/edit?usp=sharing
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Thanksgiving
Gratitude Tree 



Encourage students to reflect on what they're thankful for 
with this gratitude tree in Google Slides. 

Open this Slides deck to get started! To get access, make a 
copy by selecting File > Make a copy > Entire presentation. 

About this activity

https://twitter.com/hashtag/GoogleSlides?src=hashtag_click
https://docs.google.com/presentation/d/1QRkaX1y7uFhxZfo36468AI9xLlcu6tsy19dHRQRxFsA/edit?usp=sharing
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New Year 
Self-Reflection Countdown
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Reflecting on 2022 can set you up for more success 
and gratitude in 2023. What are you most proud of 
from last year? What skills did you learn? You and your 
students can answer those questions and more here 
with this self-reflection activity. 

Open this Slides deck to get started! To get access, 
make a copy by selecting File > Make a copy > Entire 
presentation. 

About this activity

https://docs.google.com/presentation/d/1wPLVcVwudZV4VtNAPYdIOTOEI7d0AgUkQ_tvV63dOr0/edit?usp=sharing
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Valentine’s Day



About this activity

For this assignment, customize your own heart 
shaped candy for Valentine’s Day! Write a short 
phrase, poem, or letter to share with your loved 
ones and friends.

Open this to get started. 

https://jamboard.google.com/d/18zeaGGLVH7J_koOaeIzXkJZ4KGkRnbQNNWEzS8ST6lQ/viewer?pli=1&f=0
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President’s Day 



About this activity

Encourage students to put their presidential cap on! Students 
can create their own customizable presidential campaign poster 
including creating a slogan, adding in a picture, and using the 
prompt “What I would do as president” to get their presidential 
message shared. 

Open this deck to get started. Make a copy to gain access by 
selecting File > Make a copy > Entire presentation. 

https://docs.google.com/presentation/d/1QcODL1WzIJTEjEgPr1kEwCz1R_-93OOwwWKRQ1u2zI8/edit#slide=id.g1abc89e3e1d_0_16
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International Women’s Day



About this activity

The universe is calling for a new action hero! For this activity, 
students will choose a woman in STEM to research and set up 
her super hero profile. Use the Google Slides deck to fill out 
prompts like her accomplishments, super powers, and 3 fun 
facts! 

Open this deck to get started. Make a copy to gain access by 
selecting File > Make a copy > Entire presentation. 

https://docs.google.com/presentation/d/1yQV1ggOniYaWNddGxulE9W9lI9QqUGn4lNzzaOzF4W0/edit#slide=id.g213748fee04_0_21


Proprietary + Confidential

Goal Setting Worksheet 



Help students make the most out of their school year 
and visualize their best selves with these customizable 
goal setting worksheets. Students can list goals, write a 
letter to their future selves, or create a vision board!

Open this Slides deck to get started! Make a copy by 
selecting File > Make a copy > Entire presentation. 

About this activity

https://docs.google.com/presentation/d/1QW4LCDHKvAAapljfP7AEUe_1oUfuGU_JGuKaAmU_s_M/edit?usp=sharing
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Stay Tuned for More Ways to
Celebrate Cultural Moments


